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Introduction 

Atlas is a plug-and-play service-oriented sensor and actuator platform which allows seamless 
integration of sensors and actuators into an enterprise network or existing system. It does so by 
representing sensors and actuators connected to any Atlas platform as OSGi services and allow 
their control and operation using simple Java methods. Whether the goal is an enterprise level 
solution or a small class project, Atlas bridges the hardware and software divide and allows the 
user to focus on application development. Instead of grappling with the minute physical details 
and operational quirks of these devices, developers are given the tools they need to build the 
applications they want. 

1. Atlas Out of the Box 

The Atlas package is made up of Processing Modules, Communication Modules and Device 
Interface Modules to connect sensors or actuators to the AtlaSoft Middleware. The package also 
contains a power supply or battery pack for each node, and a software CD. The CD contains all 
of the software required to use Atlas platforms, including the Knopflerfish OSGi framework, the 
AtlaSoft Middleware, as well as programming tools and device service driver bundles for various 
sensors and actuators. See Figure 01 – Atlas Sensor Platform Nodes for some examples of Atlas 
Hardware. The examples shown below include the full Wi-Fi Atlas node complete with 
Universal Patch Antenna, an Ethernet Atlas node, and a ZigBee Atlas node with Universal Patch 
Antenna. 

    �

Figure 01 – Atlas Sensor Platform Nodes 
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2 Atlas Hardware 

Most Atlas nodes have a modular architecture consisting of three stacked modules. The 
Communication Module (1) sits on top and is used to communicate between the node and the 
middleware. With wireless devices, the Communication Module is accompanied by an antenna 
that makes up the module. The Processing Module (2) in the middle is the logic center of the 
device. Finally, the Device Interface Module (3) on the bottom allows the user to connect sensors 
and actuators in a variety of configurations. The three-tier structure is displayed in Figure 02 – 
Three Module Atlas Node Configuration. 

 
Figure 02 – Three Module Atlas Node Configuration 

2.1 Atlas Communication Module 

The Communication Module is the link between an Atlas node and rest of the sensor network. It 
allows the device to communicate with the AtlaSoft Middleware or directly with other nodes. 
Communications options that connect to the Middleware currently include wired 10/100 Mbps 
Ethernet and 802.11b Wireless Ethernet (Wi-Fi). Figure 03 – Atlas Communication Modules 
shows the both types with the Atlas Ethernet Communication Module on the left and the Atlas 
Wi-Fi Communication Module on the right. Other communications platforms planned to be 
included in the middleware include ZigBee and USB (Q2 2007). 
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Figure 03 – Atlas Communication Modules 

If an Atlas node is being used on an IP network then by default the IP address of the computer 
hosting the Atlas middleware needs to be set to 192.168.0.3. If Wi-Fi communication is being 
used, a standard 802.11b wireless network also needs to be set up which broadcasts the SSID 
ATLAS (case sensitive). The Ethernet and Wi-Fi nodes are capable of having static or dynamic 
IP addresses. 

2.2 Atlas Processing Module 

The Processing Module is the center of an Atlas node. It is in charge of overall functions 
including network communication and sensor and actuator integration. Figure 04 – Atlas 
Processing Module shows the Processing Module in the middle position of an Atlas node. 

 
Figure 04 – Atlas Processing Module 
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2.3 Atlas Device Interface Module 

The final integral part of an Atlas node is the Device Interface Module. The Device Interface 
Module allows the physical connection of sensors and actuators to Atlas nodes.  The three 
different types of modules that can be connected to the Atlas Sensor Platform include a 32 
Analog Sensor Interface Module, a Servo Interface Module, and a Digital Contact Interface 
Module. These three modules are discussed in greater detail in sections 2.3.1, 2.3.2 and 2.3.3, 
respectively. 

2.3.1 32 Analog Sensor Interface Module 

This module allows up to 32 analog sensors to be connected to a single node by multiplexing the 
on board analog to digital converter input pins. Virtually any analog sensor can be converted 
using Atlas – provided the power requirements for the sensor are met and the sensor outputs a 
voltage between 0 V and +2.5 V DC. Looking at Figure 05 – 32 Analog Sensor Interface 
Module, each connection channel is labeled on the bottom side (right half of the figure) of the 
module and has a pin for power (+3.3 V DC), ground, and signal. These channels correspond 
directly to the Node Configuration Tool channels discussed in Section 4.3 – Node Configuration. 

   
Figure 05 – 32 Analog Sensor Interface Module 
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2.3.2 Servo Interface Module 

The Servo Interface Module allows up to 6 standard RC servos to be connected and controlled 
using a single node. Servos are controlled by three wires: ground (brown or black), power (red), 
and the control signal (any other color). The ground, power, and signal connections can be seen 
in Figure 06 – Servo Interface Module. The Node Configuration Tool channels for servo 
connections are defined as follows: 

Channel 0: OCR1A 
Channel 1: OCR1B 
Channel 2: OCR1C 
Channel 3: OCR3A 
Channel 4: OCR3B 
Channel 5: OCR3C 

Due to the relatively high power requirements of servos, especially while under load, this module 
requires its own DC power supply (2.1 mm center positive plug with 6 V to 30 V DC) when 
using more than one servo. When using only one servo, however; the platform power plug may 
be connected to the processing module with the use of the included daisy chain power connector. 

    
Figure 06 – Servo Interface Module 
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2.3.3 Digital Contact Interface Module 

The Digital Contact Interface Module allows up to 16 digital contact sensors to a single node. A 
digital contact sensor could be a magnetic or mechanical switch or pushbutton, but can also 
include an externally threshold triggered analog sensor. Each channel on the Digital Contact 
Interface Module is pulled high (logic 1) to +3.3 V DC using 10 k�  SIP resistor packs. The 
digital contact sensors would then pull the signal low (logic 0). A change is detected anytime the 
signal switches from high to low or low to high. As can be seen in Figure 07 – Digital Contact 
Interface Module, the channel numbers are printed on the circuit board and correlate to the Node 
Configuration Tool channels as follows: 

Channel 0: E0 
Channel 1: E1 
Channel 2: E2 
Channel 3: E3 
Channel 4: E4 
Channel 5: E5 
Channel 6: E6 
Channel 7: E7 
Channel 8: F7 
Channel 9: F6 
Channel 10: F5 
Channel 11: F4 
Channel 12: F3 
Channel 13: F2 
Channel 14: F2 
Channel 15: F1 

 
Figure 07 – Digital Contact Interface Module 
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3 Installing the Software 

1. Download and install the Java Software Development Kit version 1.4.2 (J2SDK) or 
above. The J2SDK can be downloaded from the web or it can be run from the Install 
Files directory on the software CD. 

2. Copy the “AtlaSoft Middleware” directory on the software CD into a directory on a 
local hard drive. Run the executable framework.jar  file from the command line: 
 
> java –jar framework.jar 
 
Alternatively, create a shortcut or script to launch the framework instead of executing 
it from the command line. When the framework is launched for the first time, the 
directory fw  will be created. All necessary bundles will load and the AtlaSoft 
Middleware is now ready to use. 
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4 Web Based Atlas Configuration and Admin Interface  

The Atlas platform includes a simple, easy-to-use web interface. This interface shows the status 
of the entire network as well as allows for individual nodes to be identified and configured. Once 
the Atlas middleware is successfully running inside the OSGi framework, open a web browser 
(IE, Firefox, or Opera) and access the Atlas Platform Configuration and Administration website. 
The address for the web server will be the same as the computer on which your OSGi framework 
is running. The port on which the webserver listens is specified in the file 
webproperties.props  located in the same directory as WebInterface.jar . Typically, the 
address used to access the web server is as follows: 
 
http://localhost:8040/  
 
If the port number is changed in the webproperties.props  file, be sure to refresh the Web 
Interface bundle inside the framework so the new settings may take effect. 

 
Figure 08 – Atlas Web Interface Home Page 

4.1 Bundle Repository 

The Bundle Repository page allows for managing the service driver bundles required by the 
different sensors and actuators deployed in the network. Make sure the service driver bundles for 
the sensors and actuators being used are present. If not, upload the service driver bundle JAR 
files. 
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To upload a new bundle, click on “Browse” and select the service bundle JAR to be added or 
updated in the repository. Then click “Update Repository.” To delete a bundle, select the check 
box next to the bundle name and click on the “Delete Bundle” button. 

 
Figure 09 – Atlas Bundle Repository Web Page 

4.2 View Network 

The View Network page lists all the nodes which are currently online in the sensor network. To 
add a new node to the network, power up the node and allow the node to connect to the 
framework. After a delay of about 30 seconds the node will show up in the View Network page. 
If the node does not appear within 90 seconds, power cycle the node and try to connect it again. 
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Figure 10 – View Network Status Web Page 

4.3 Node Configuration 

To configure an Atlas node, go to the “View Network Page” and click on the node that is to be 
configured. Alternatively, click on the “Configure Nodes” tab and enter the Node Id manually. 
The configuration page the node will load. A number of configuration settings may be changed 
by user. This includes network settings as well as interface module settings. To change the 
Device Interface Module, select the particular module that is physically connected to the 
deployed platform then click “Change Connection Interface.” To configure a sensor or actuator 
with a particular node, find the channel where the sensor or actuator is connected and click on 
the drop down box. Next, select the type of sensor or actuator from the list. To aid in this 
process, the channels numbers for each Device Interface Module are printed on the bottom of the 
Atlas node. Finally, to complete the configuration process, click “Configure Node.” 
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Figure 11 – Node Configuration Web Page 
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 The node will restart and the corresponding device services will temporarily disappear from the 
framework. After approximately 30 seconds, the node will rejoin the network and the new 
devices will automatically appear as OSGi services. At this point, the sensors and actuators are 
ready to be used in an application. In case the node fails to come back on-line due to network 
failure or loss of power, simply power cycle the node to allow it to rejoin the network. 

 
Figure 12 – Node Configuration Successful 
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5 Integrated Development Environment (IDE) 

Along with the hardware and configuration tool, the complete Atlas platform includes a simple, 
easy-to-use development tool that extends the capability of the popular open-source integrated 
development environment (IDE) Eclipse in the form of a plug-in. This plug-in provides several 
tools for working with an Atlas deployment. It allows application developers to browse the 
online devices and develop new services and applications based on them. Developers can also 
browse and modify existing applications. Applications developed using this plug-in can be 
remotely deployed to a system running the Atlas platform. The software employs the “Design by 
Selection” approach for service design, and provides templates of source code that allow the 
developers to concentrate on implementing the logic for the service without worrying about 
details of writing OSGi bundles. 

Eclipse and the Atlas plug-in should be set up on computers intended to be used as development 
environments. This can be the same computer where the OSGi framework is running or a 
separate machine. 

5.1 Plug-In Prerequisites 

Before the Atlas plug-in for Eclipse can function properly, some software needs to be installed. 
In addition to the JDK and Knopflerfish OSGi reference implementation mentioned in section 3, 
the user also needs to install Eclipse. Eclipse can either be downloaded from the web or accessed 
on the software CD in the “Install Files” directory. The Atlas plug-in currently supports both 
Eclipse versions 3.1 and 3.2. 

Please note that for an application to compile, the application must be linked against 
framework.jar (in the same directory where the AtlaSoft Middleware resides) provided in the 
Atlas installation. In Eclipse, navigate to Project > Properties > Java Build Path, and select the 
Libraries tab. Next, click the “Add External JAR” button and select a local copy of 
framework.jar . 

5.2 Installation and Configuration 

The plug-in must be manually installed using the software CD. The following are the instructions 
for installation and configuration of the plug-in. 

3. Manually Install the Plug-In: 

a. Shutdown Eclipse if it is currently running 

b. Copy the plug-in from the Programming Tools\Eclipse Plugin  directory on 
the software CD to the plugins  directory of the Eclipse installation 

4. Configure the Plug-In 

a. Create a text file called properties.txt  in the application workspace directory. 
In the file paste in the following text: 
 
port = 23 
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localdir = C:\\workspace\\runtime-EclipseApplicatio n\\ 
framework = C:\\Program Files\\Knopflerfish\\knopfl erfish.org\\osgi\\framework.jar 

 

b. In properties.txt , edit the port number to reflect the port number used by the 
OSGi framework.  In addition, edit the path to the current workspace as well as 
the Knoplerfish OSGi framework to reflect where on the local machine the 
framework is installed. 

5. Ensure the BundleDownloader  and BundleUploader  bundles are running in the 
OSGi framework. 

6. Restart Eclipse 

5.3 Create New Services and Applications Using the Atlas Plug-In 

The following is a short tutorial on how to use Atlas plug-in to develop new services and 
applications.  

1. Switch to OSGi Perspective 

a. Navigate to Window > Open Perspective  > Other… and select OSGI Perspective 
from the list. 

 
Figure 13 – Selecting a Different Eclipse Perspective 
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Figure 14 – Select Perspective Dialog Box 

OSGi Perspective should now become the active perspective in Eclipse with the views as 
discussed below. 

There are a total of four new views in OSGi Perspective: 
1. Sensor List 
2. Actuator List 
3. Bundle List 
4. Manifest Info 

The Sensor List, Actuator List and Bundle List views are three views that show lists of 
bundles representing sensors, actuators and others that are currently available in the OSGi 
platform that is connected by the plug-in. Manifest Info View presents the information 
about the bundle (sensor/actuator/other) that is currently selected in one of the three other 
views. 

 
Figure 15 – Views When Using the OSGi Perspective 
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2. Connect to Remote OSGi Platform 

a. Navigate to File > OSGi Platform Connection and type in the hostname or IP 
address of the target OSGi framework. The plug-in is designed to connect to a 
running OSGi framework  

 
Figure 16 – Navigating to OSGi Platform Connection 

3. Design by Selection 

a. The first step in designing a new service or bundle is to select the sensors, 
actuators or other bundles that are needed for the new services. Double click on 
the name of the sensor, actuator or other bundle that is to be used as part of the 
new service. The JAR file of the selected sensor, actuator or other bundle will be 
downloaded automatically. 

b. Open the newly created project in the Package Explorer View to check if the JAR 
file has been downloaded properly. 

c. Repeat steps a and b until all required sensor, actuator or other bundle JAR files 
have been downloaded. 

d. Repeat steps a and b for AtlasDev.jar . 

* Atlas-Developer-API is the standard Atlas programming API that should be included in all new 
projects. 
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4. Create a New Bundle Project 

a. Choose the fourth icon (a folder with a green plus sign: ) in the Sensor 
List/Actuator List/Bundle List view. 

b. Type in the project name and the target package name. A new project with 
bundles will be automatically created. As a general rule, avoid spaces in the 
project name as this name will also be used as the class name for the project. The 
new project includes template source files for interface, activator and 
implementation. The plug-in automatically sets the Java and Ant build paths. 

5. Modify the Interface, Activator and Implementation Classes/Interfaces 

a. The user should put the interface to be exported to other services and 
programmers in the interface class. 

b. The Activator class is used for managing the life cycle of the OSGi bundles. This 
includes a start-up setup in start method and a clean-up operation in stop method.  
This class also binds the variables to the handles of existing instances of sensors 
and actuators. 

c. The Implementation class is where the service logic should be implemented. 

6. Deploy the Newly Developed Bundle to the OSGi Framework 

a. In the Package Explorer View, select the project to be deployed to the target 
OSGi platform. 

b. Navigate to File > Deploy Bundle, and type in the hostname or IP address of the 
target OSGi platform. Alternatively, on the toolbar there is a folder with an 
upward arrow icon  that allows programmer to deploy to the target OSGi 
platform. When instructed to deploy the bundle to the OSGi platform, the plug-in 
first create the jar file by running the ANT build.xml file. 

c. Repair any compilation errors, if any. 

d. When the build process succeeds, the newly created JAR file is uploaded to the 
target OSGi platform. The plug-in contacts the OSGi platform to load and activate 
the new service if all dependencies are satisfied. 


